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NuSRS 2.0 Introduction
Automatic tool to support requirement specification 
and formal verification of NuSCR model

Development language: Java
Development environment: eclipse 3.1 (JDK 1.5)
Environment
4Windows OS(recommendation)
4 PC with JDK or JRE (ver. 1.5 or higher) installed
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NuSRS 2.0 Structural Overview
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NuSRS2.0 Constructs
Menu

Toolbar

Hierarchy
Window

Diagrams
Description

Window

Type & Console
Window
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Menu Functions, Toolbar
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Menu > File 

File
4 New – Create new file
4 Open – Open file
4 Close File – Close file
4 Save – Save file
4 Save As – Save file as another 

name
4 Save Without Graphical Info

– Save file without graphical 
information

4 Save as Image
– Save file as image

4 Print – Print
4 Exit – Exit program
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Menu > Edit

Edit
4Cut – Cut Selected
4Copy – Copy Selected
4Paste – Paste Selected
4Delete – Delete Selected
4SelectAll – Select All nodes
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Menu > View 

View
4FIND – Find node
4View IO Vars – View list of IO 

Variables
4Zoom In – Zoom In
4Zoom Out – Zoom Out
4Zoom Selected – Zoom 

Selected
4Fit to Window – Zoom in or 

out depending on window size
4Auto Align – Auto Align
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Menu > Window 

Window
4Close – Close the editing 

Window
4Close All Windows – Close 

all Windows
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Menu > Help 

Help
4About – Give information 

on NuSRS



12

Create new file (1/2)

1. Select File > New in Menu. 
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Create new file (2/2)

2. Under the hierarchy, the root is created inside the 
description window, and a window for drawing the 
root node is created



14

Load file (1/3)
1. Select File > Open in Menu.
4 Open files that were created in NuSRS with .xml 

suffix
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Load file (2/3)

2. When the dialog box opens, select the file to 
load. 
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Load file (3/3)

3. File loading completed.

Structure
of the 
loaded
file

Path of the loaded file

Details of
the loaded 
file

Diagram
of the 
loaded
file
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Save file

1. Select File > Save in Menu. The current file 
is then saved.
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Save As (1/2)

1. Select File > Save As in Menu.
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Save As (2/2)

2. When the dialog box opens, input a file name and 
click save. The current file is saved.

Save as
Test1.xml
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Save without Graphical Info (1/2)

1. Select File > Save Without Graphical Info in 
Menu.
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Save without Graphical Info (2/2)
2. When the dialog box opens, input a new file name 

and click save. The current file is saved without 
graphical information.

Save as 
user 
assigned
name.xml
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Save as Image (1/2)

1. Select File > Save as Image in Menu.
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Save as Image (2/2)

2. When the dialog box opens, input a new file name and click 
save. The current file is saved as an image file.

Save as 
user 
assigned
name.jpg
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Print

1. Select File > Print in Menu.
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Edit > Cut (1/2)

1. Select the area to be cut by clicking the left 
mouse button or by drag & drop.
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Edit > Cut (2/2)

2. Select Edit > Cut (or press Ctrl + X). The 
selected area is then cut. 
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Edit > Copy (1/2)

1. Select the area to be copied by clicking the 
left mouse button or by drag & drop.
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Edit > Copy (2/2)

2. Select Edit > Copy (or press Ctrl + C). The 
selected area is then copied. 
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Edit > Paste (1/4)

1. Select Edit > Paste.  (or press Ctrl + V)
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Edit > Paste (2/4)

2. Selected constructs are pasted with different 
names.
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Edit > Paste (3/4)

3. Select the pasted node, click the right mouse 
button and select rename.
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Edit > Paste (4/4)

4. Change the name of the pasted node 
appropriately.



33

Edit > Delete (1/3)

1. Select the area to be deleted by clicking the 
left mouse button or by drag & drop.



34

Edit > Delete (2/3)

2. Select Edit > Delete. (or press Delete key)
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Edit > Delete (3/3)

3. Selection is deleted.
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Edit > Select All (1/2)

1. Select Edit > Select All. (or press Ctrl + A)
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Edit > Select All (2/2)

2. All nodes in the current view are selected.
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View > Find (1/3)

1. Select View > Find in Menu.



39

View > Find (2/3)

2. When the dialog appears, input the name of 
a node which users want to find.
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View > Find (3/3)

3. Focus moves to the found node.
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View > View I/O Vars (1/2)

1. Select View > View IO Vars in Menu.
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View > View I/O Vars (2/2)

2. List of I/O variables appears.
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View > Zoom In (1/2)

1. Select View > Zoom In. (or press + in the 
keypad)
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View > Zoom In (2/2)

2. Zoom in on the current active window.
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View > Zoom Out (1/2)

1. Select View > Zoom Out. (or press – in the 
keypad)
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View > Zoom Out (2/2)

2. Zoom out of the current active window.
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View > Zoom Selected (1/3)

1. Select the area to be zoomed by clicking the 
left mouse button or by drag & drop.
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View > Zoom Selected (2/3)

2. Select View > Zoom Selected.
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View > Zoom Selected (3/3)

3. The selected image is zoomed in to fill the 
current window space.
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View > Fit to Window (1/2)

1. Select View > Fit to Window.
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View > Fit to Window (2/2)

2. The current active image is adjusted to fit the 
window space.
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View > Auto Align (1/2)

1. Select View > Auto Align.
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View > Auto Align (2/2)

2. Nodes and arrows in the current active 
window are automatically aligned and placed.
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Close Window

1. Select Window > Close. The current active 
window is then closed.



55

Close all Windows (1/2)

1. Select Window > Close All. 
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Close all Windows (2/2)

2. All open windows are then closed.
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Inquire Program Information (1/2)

1. Select Help > About.
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Inquire Program Information(2/2)

2. Information of the NuSRS program is given.
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Toolbar

File Menu Edit Menu View Menu

New

Open

Save

Exit

Zoom 
In

Zoom 
Out

Zoom 
Selected

Fit to 
Window

Auto
Align

Check Menu

Cut

Copy

Paste

Delete

Select 
all

Find 

View 
IO 

Vars Quick 
Check

Model 
Check

Debug
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Hierarchy Window
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Hierarchy Window
Hierarchy Window 
shows the 
hierarchical structure 
of the opened file
Root is the highest 
FOD.
By double clicking a 
tree branch, the 
corresponding FOD is 
opened or becomes 
active.
Maximize button

Maximize
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Description Window
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Description (1/9)

Gives detailed 
description of the 
current active window.
FOD name
4Description window has 

the current active 
window’s name (node 
name) as the root.

Maximize Button

Maximize
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Description (2/9)

Description
4Shows information of the 

current active diagram
4The node can be edited 

by double clicking the 
paper shaped icon.

4(Applies to all FOD, SDT, 
FSM, TTS)
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Description (3/9)

Template Number
4Logic represented by 

FSM or TTS has a certain 
type of template. Input the 
corresponding template 
number.

4The node can be edited 
by double clicking the 
paper shaped icon.

4(Applies only to FSM, 
TTS)
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Description (4/9)

Input
4Shows all the input 

variables of the current 
active window. 

4Impossible to make direct 
changes in the 
description window.

4When the input variable 
name in the parent FOD 
is changed, the same 
variable in the child FOD 
is automatically adjusted.

4(Applies to all FOD, SDT, 
FSM, TTS)
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Description (5/9)
Output
4 Shows all the output variables 

of the current active window. 
4 Impossible to make direct 

changes from the description 
window.

4When the output variable name 
in the parent FOD is changed, 
the same variable in the child 
FOD is automatically adjusted 

4 f_, h_, and th_ nodes have only 
one output variable.

4 (Applies to all FOD, SDT, FSM, 
TTS)
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Description (6/9)
Memorizable Variable of 
External input
4 Declare a variable that 

describes the previous scan 
value of an input variable

4 By adding a suffix such as _t0, 
_t1 to the input variable name, 
define which scan value it is.  

t0 is one scan before, t1 is 
two scans before etc. 

4When “Memorizable variable of 
External input” is selected, Add, 
Delete and Edit  can be 
performed by clicking the right 
mouse button.

4 (Applies only to FSM,TTS)
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Description (7/9)

Constant
4Declare a constant value 

to be used in the 
corresponding diagram

4When the “Constant” is 
selected, Add, Delete and 
Edit can be performed by 
clicking the right mouse 
button.

4(Applies to all FOD, SDT, 
FSM, TTS)



70

Description (8/9)

Local Clock Variable
4When TTS requires a 

time related transition 
label, a clock variable 
must be declared.

4When the “Local Clock 
Variable” is selected, Add, 
Delete and Edit can be 
performed by clicking the 
right mouse button.

4(Applies only to TTS)
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Description (9/9)

Previous State Variable
4 Declare a variable that 

describes the previous scan 
value of an output variable

4 By adding a suffix such as _t0, 
_t1 to the output variable name, 
define which scan value it is.  

t0 is one scan before, t1 is 
two scans before etc.

4When the “Previous State 
Variable” is selected, Add, 
Delete and Edit  can be 
performed by clicking the right 
mouse button.

4 (Applies only to FSM,TTS)
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FOD,FSM(TTS),SDT 
Edit Window
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FOD Edit Window – Full Screen

When a group node starting with g_ is double clicked 
Window that can edit the FOD
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FOD Edit Window – Details

Tool 
Buton

FOD

Root or name of 
group node Close
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FOD Edit Window – Button (1/9)

Select
4 Used to select each node and transition
4 After clicking the selection button, click the 

node and transition in the edit window with 
the left mouse button 

4 Drag & drop is available for multiple 
selections.
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FOD Edit Window – Button (2/9)

IO node
4 Used to edit input output nodes.
4 IO node can only be connected to one outgoing 

transition or incoming transition.
4 IO node can only be created in the top most FOD; 

once created in the top most FOD it is 
automatically created in the lower FOD.

4 When an IO node is deleted from a lower FOD, 
the transition from the top most FOD is deleted, 
but the IO node itself is not deleted.
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FOD Edit Window – Button (3/9)

IO node (cont.)
1. Click the IO node button and click the left mouse 

button on the editing window.  
2. When a dialog box for entering the node’s name 

is shown, enter a node name and click ok.
3. As soon as the node’s name is entered the node 

is edited. 
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FOD Edit Window – Button (4/9)

Group node
4 Used to edit group nodes starting with g_.
4 If the name does not begin with a g_, an error 

message is given and the name is re-entered.

1. Click the group node button and click the left 
mouse button on the edit window. 

2. When a dialog box for entering the node’s name 
is shown, enter a node name and click ok.

3. As soon as the node’s name is entered the node 
is edited. 
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FOD Edit Window – Button (5/9)

Function node
4 Used to edit function nodes starting with f_.
4 If the name does not begin with a f_, an error 

message is given and the name is re-entered.

1. Click the function node button and click the left 
mouse button on the edit window. 

2. When a dialog box for entering the node’s name 
is shown, enter a node name and click ok.

3. When a dialog box for entering the node’s name 
is shown, enter a node name and click ok.
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FOD Edit Window – Button (6/9)

History node
4 Used to edit history nodes starting with h_.
4 If the name does not begin with a h_, an error 

message is given and the name is re-entered.

1. Click the history node button and click the left 
mouse button on the edit window. 

2. When a dialog box for entering the node’s name 
is shown, enter a node name and click ok.

3. When a dialog box for entering the node’s name 
is shown, enter a node name and click ok.
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FOD Edit Window – Button (7/9)

Timed History node
4 Used to edit timed history nodes starting with th_.
4 If the name does not begin with a th_, an error 

message is given and the name is re-entered.

1. Click the timed history node button and click the 
left mouse button on the edit window. 

2. When a dialog box for entering the node’s name 
is shown, enter a node name and click ok.

3. When a dialog box for entering the node’s name 
is shown, enter a node name and click ok.
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FOD Edit Window – Button (8/9)

Transition
4 Used to edit transitions between nodes.
4 A Self-Transition in FOD is not allowed.
4 After clicking the Transition button once, multiple 

transitions can be drawn until another button is 
clicked.

4 As soon as a transition from an IO node is drawn, 
we decide whether it is an input or output node, 
and this information change automatically in the 
description window.
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FOD Edit Window – Button (9/9)

Transition (cont.)
1. Click the Transition button.
2. Click and drag the Source node, and drop it at 

the Destination node.
4 When making a transition between group nodes, must 

input a transition name.
4 A transition name must be one of the output nodes’ 

names from the source group node.
4 When a group node group node transition is drawn, a 

input node with the same name is automatically created 
in the target group node.

4 When a transition name is not one of the output node’s 
names in the source group node, then an output node 
with the corresponding name is automatically created.
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FOD Edit Window – Rename Node

1. Select the node, right click and select 
Rename.
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FOD Edit Window – Rename Node

2. Change the name when the node name becomes a 
changeable state, then click the left mouse button 
and the renaming is done.
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SDT Edit Window – Full Screen

When double clicked a node starting with f_
A table-like window that can edit SDT
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SDT Edit Window – Details (1/2)

SDT

Function node 
name

Close
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SDT Edit Window – Details (2/2)

Structured Decision Table
4A table based on NuSCR semantics.
4By clicking the right mouse button at each 

row/column, a row/column can be added, copied, 
pasted, deleted etc.
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FSM, TTS Edit Window – Full Screen

When a node starting with h_ or th_ is double clicked
A window that can edit FSM and TTS
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FSM, TTS Edit Window – Details

Tool 
button FSM or 

TTS

History node or
Timed history node 
name

Close
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FSM, TTS Edit Window – Button (1/3)

Select
4 Used to select the State and transition.
4 After clicking the Selection button, click the 

left mouse button on the state and transition 
to be edited in the edit window.

4 Drag & drop is possible for Multiple 
Selection.
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FSM, TTS Edit Window – Button (2/3)

State
4 Used to draw States.
4 A State name must not include blank spaces or 

symbols.
1. Click the State button and click the left mouse 

button on the edit window.
2. When a dialog box for entering the State name 

pops up, enter the State name and click ok.
4 If the State name is entered wrong, an error 

message is given and the name is re-entered.
3. As soon as the State name is inputted, the state is 

edited.
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FSM, TTS Edit Window – Button (3/3)

Transition
4 Used to edit transitions between States.
4 In FSM and TTS, at most one self-Transition can 

be drawn.
4 Once clicking the Transition button once, many 

transitions can be drawn until another button is 
pressed.

1. Click the Transition button.
2. Click the Source state and drag, drop at the 

Target state.
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FSM, TTS Edit Window – Rename State (1/2)

1. Click the state, right click and select Rename.
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FSM, TTS Edit Window – Rename State (2/2)

2. Change the name when the node name becomes a 
changeable state, then click the left mouse button 
and the renaming is done.
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FSM, TTS Edit Window – Set Initial State (1/2)

1. Click the state, then right click and select set 
initial state.
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FSM, TTS Edit Window – Set Initial State (2/2)

2. The selected state becomes an initial state, and the 
original initial state becomes a normal state.
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Type Window
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Type Window
A window that records all variables used in the 
diagram, and allows editing of the variable types 



100

Edit Type Window (1/3)

1. Click the variable and double click.
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Edit Type Window (2/3)

2. In the variable type dialog box select the type 
and click ok. 

change the original setting
of boolean into range type
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Edit Type Window (3/3)

3. The variable’s type has been changed.
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Other supported item functions

Check whether variable names are repeated 
or not.
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Quick Check



Verification > Quick Check (1/4)

1. Select Verification > Quick Check.

105



Verification > Quick Check (2/4)

2. See the Result on the right of the Type Window. 

106



Verification > Quick Check (3/4)

Quick Check checks diagram which is 
being edited and child nodes of the 
diagram.

To check entire model, execute Quick 
Check when you are editing root node.
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Verification > Quick Check (4/4)

Errors checked by Quick Check
1. Undefined variables in SDT’s Conditions and Actions
2. Syntax errors in SDT conditions and actions
3. More than one action allocated in SDT conditions
4. Undefined variables in FSM and TTS transitions
5. Syntax errors in FSM and TTS Transitions 
6. FOD, FSM and TTS nodes which have no transition
7. Nodes unreachable from initial state in FSM and TTS
8. Output variable and its connected node have 

different names

108
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Model Checking
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Verification > Model Checking (1/6)

1. Select Verification > Model Checking.
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Verification > Model Checking (2/6)
2. A result window that converts the current window’s 

NuSCR contents into SMV input language is given.
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Verification > Model Checking (3/6)

3. After entering the verification properties, click 
the Apply button and it is applied to the SMV 
input (SMV input window is editable)

Input verification 
properties (CTL)
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Verification > Model Checking (4/6)

4. Click the Execution button and the SMV tool is 
executed.
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Verification > Model Checking (5/6)

5. Click Prop > Verify or Verify all in SMV.
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Verification > Model Checking (6/6)

6. Check the verification results and analyze.
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