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1 NuSRS 2.0 Introduction 
 

 Automatic tool that supports particular requirements and verifications 

described in NuSCR  

 

 Typical improvements of NuSRS 2.0  
 Maximize the user convenience  

 Add Edit Menu (Copy, Paste, Delete)  

 Add View Menu (Zoom In, Zoom Out, Zoom Selected, Fit to Window, Auto 

Align)  

 Attain more information 

 Add Description, Type Window, Console Window  

 Examine strict consistency while editing 

 Strengthen error message functions and auto formation function to prevent user 

input error to the maximum 

 User friendly interface 

 

 

2 Development & Execution environment 
 

 Development language  
 Java 

 

 Development environment  
 eclipse 3.1 (JDK 1.5) 

 

 Environment 
 Windows OS(recommendation) 

 PC with JDK or JRE (ver. 1.5 or higher) installed 

 

 

3 NuSRS 2.0 function components 
 

 



4 Environment components 
 

 
 
 

5 Detailed description of NuSRS 2.0 functions 
 

5.1  Menu functions 
5.1.1 Menu > File 
 

 File 

 
 New –Create new file  

 Open – Load file  

 Close File – Close file  

 Save – Save file  

 Save As – Save file as another name  

 Save Without Graphical Info – Save file  

Without Graphical Info 

 Save as Image – Save file as Image 

 Print – Print file 

 Exit – Exit program  

 
 

 



5.1.2 Menu > Edit 
 

 Edit 

 
 Cut – Cut Selected. 

 Copy – Copy Selected 

 Paste – Paste Selected 

 Delete – Delete Selected 

 SelectAll – Select all of objects in the window. 

 

 

 

 

 

 

 

5.1.3 Menu > View 
 

 View 

 
 FIND – Find node. 

 View IO Vars – Show the list of I/O Variable. 

 Zoom In – Zoom In  

 Zoom Out – Zoom Out  

 Zoom Selected – Zoom Selected 

 Fit to Window – Zoom in or out depending  

on window size  

 Auto Align – Auto Align  

 

 

5.1.4 Menu > Window 
 

 Window 

 
 Close – Close the editing Window  

 Close All Windows – Close all Windows 

 

 

 

 

 

 



5.1.5 Menu > Help 
 

 Help 

 
 About – Give information on NuSRS  

 
 
 
 
 
 
 

 
 
 
5.1.6 Create new file 
 

1. Select File > New in Menu.  

 

 
 

 



2. Under the hierarchy, the root is created inside the description window, 

and a window for drawing the root node is created 

 

 
 

 

 

5.1.7 Load file 
 

1. Select File > Open in Menu.  
 Open files that were created in NuSRS with .xml suffix  

 

 

 

 



 

2. When the dialog box opens, select the file to load.  

 

 
 

 

 

3. File loading completed. 

 

 



5.1.8 Save file 
 

1. Select File > Save in Menu. The current file is then saved. 

 

 
 

 

 
 

5.1.9 Save As 
 

1. Select File > Save As in Menu. 

 

 



 

 

2. When the dialog box opens, type in the new file name and click save. 

The current file is then saved. 

 

 
 

 

 

5.1.10 Save without Graphical Info 
 

1. Select File > Save Without Graphical Info in Menu. 

 

 



2. When the dialog box opens, type in the new file name and click save. 

The current file is then saved without graphical information. 

 

 
 

 

 

5.1.11 Save as Image 
 

1. Select File > Save as Image in Menu. 

 



2. When the dialog box opens, type in the new file name and click save. 

The current file is then saved as Image. 

 

 
 

5.1.12 Print 
1. Select File > Print in Menu. 

 

 

 
 



5.1.13 Edit > Cut 
1. Select the area to be cut by clicking the left mouse button or by drag & drop. 

 
 

2. Select Edit > Cut. The selected area is then cut. (or press Ctrl + X) 

 

 

 

 

 



 

5.1.14 Edit > Copy 
 

1. Select the area to be copied by clicking the left mouse button or by 

drag & drop. 

 

 

 

2. Select Edit > Copy(or press Ctrl+C). The selected area is then copied.  

 

 



 

5.1.15 Edit > Paste 
 

1. Select Edit > Paste.(or press Ctrl+V) 

 

 
2. A node is pasted if a copied area exists, and different names are given. 

 

 
 

 



3. Select the pasted node, click the right mouse button and select rename. 

 

 
 

 

 

4. Change the name of the pasted node appropriately. 

 

 
 

 

 



5.1.16 Edit > Delete 
 

1. Select the area to be deleted by clicking the left mouse button or by 

drag & drop. 

 

 
 

 

 

 

2. Select Edit > Delete. 

 

 



3. Selection is deleted. 

 

 
 

5.1.17 Edit > Select All 
1. Select Edit > Select All. (or press Ctrl + A) 

 

 
 

2. Every node in current view is selected. 



 

 

 

 

 
5.1.18 View > Find 

1. Select View > Find in Menu. 

 

 
 

 



2. When the dialog appears, type the name of a node which want to find. 

 
 

3. Focus moves to the node. 

 



 
5.1.19 View > View IO Vars 

1. Select View > View IO Vars in Menu. 

 

 
 

 

2. List of I/O Variables appears. 

 
 
 



5.1.20 View > Zoom In 
 

1. Select View > Zoom In. 

Or press ‘+’ in the keypad. 

 
 

 

 

2. Zoom in on the current active window. 

 

 



5.1.21 View > Zoom Out 
 

1. Select View > Zoom Out. 

Or press – key in the keypad. 

 
 

 

 

2. Zoom out of the current active window. 

 

 
 



5.1.22 View > Zoom Selected 
 

1. Select the area to be zoomed by clicking the left mouse button or by 

drag & drop. 

 

 
 

 

 

2. Select View > Zoom Selected. 

 

 
 



 

 

 

3. The selected image is zoomed in to fill the whole window space. 

 

 
 

5.1.23 View > Fit to Window 
 

1. Select View > Fit to Window. 

 

 



2. The current active image is adjusted to fit the window space. 

 

 
 

 

 

5.1.24 View > Auto Align 
 

1. Select View > Auto Align. 

 

 
 



2. The current active image’s node and arrow positions are auto aligned 

and placed. 

 

 
 

 

 

5.1.25 Close Window 
 

1. Select Window > Close. The current active window is then closed. 

 

 



5.1.26 Close all Windows 
 

1. Select Window > Close All.  

 

 
 

 

 

2. All open windows are then closed. 

 

 



5.1.27 Inquire Program Information 
 

1. Select Help > About. 

 

 
 

 

 

2. Information on the NuSRS program is given. 

 

 
 



5.2  Toolbar 
 

 
 

 

 

 

 

 

 

5.3  Hierarchy Window 
 

 Hierarchy Window shows the class  

structure between a file’s FOD. 

 Root is the highest FOD. 

 By double clicking a tree branch, the  

corresponding FOD is opened or becomes  

active. 

 Maximize button 

 



5.4  Description Window 
 

 Gives detailed description on the current  

active window. 

 FOD name  

 Description window has the current active  

window’s name (node name) as the root. 

 Maximize Button  

 

 

 

 

 

 

 Description 

 Record a description on the current active  

diagram 

 The node can be edited by double clicking the  

paper shaped icon.  

 (Applies to all FOD, SDT, FSM, TTS) 

 

 

 

 

 

 

 

 

 Template Number 

 Logic represented by FSM,TTS has a certain  

type of template. Enter the corresponding template  

number. 

 The node can be edited by double clicking the paper  

shaped icon. 

 (Applies only to FSM, TTS) 

 

 

 

 

 

 



 Input 

 Shows all the input variables of the current active  

window.  

 Impossible to make direct changes from the  

description window. 

 When the root FOD’s input variable is changed, the  

child nodes’ variable names are automatically  

adjusted. 

 (Applies to all FOD, SDT, FSM, TTS) 

 

 

 

 

 Output 

 Shows all the output variables of the current active  

window.  

 Impossible to make direct changes from the  

description window. 

 When the root FOD’s input variable is changed,  

the child nodes’ variable names are automatically  

adjusted. 

 f_, h_, th_ nodes have one output variable. 

 (Applies to all FOD, SDT, FSM, TTS) 

 

 

 

 

 Memorizable Variable of External input 

 Declare a variable that describes the previous  

period value of the input variable 

 By adding a suffix such as _t0, _t1 to the input  

variable name, define which period value it is.   

 t0 is one period before, t1 is two periods  

before etc.  

 When Memorizable variable of External input is  

selected, Add, Delete, Edit can be performed by  

right clicking the mouse button. 

 (Applies only to FSM,TTS) 

 

 

 

 

 



 Constant 

 Declare a constant value to be used in the  

corresponding diagram 

 When the constant is selected, Add, Delete,  

Edit can be performed on the constant by clicking  

the right mouse button. 

 (Applies to all FOD, SDT, FSM, TTS)  

 

 

 

 

 

 

 

 Local Clock Variable 

 When TTS requires a time related transition  

label, a clock variable must be declared. 

 When the local clock variable is selected, Add,  

Delete, Edit can be performed on the constant by  

clicking the right mouse button. 

 (Applies only to TTS)  

 

 

 

 

 

 

 

 Previous State Variable 

 Declare a variable that describes the previous  

period value of the output variable 

 By adding a suffix such as _t0, _t1 to the  

output variable name, define which period value  

it is.   

 t0 is one period before, t1 is two periods  

before etc.  

 When Memorizable variable of External input is  

selected, Add, Delete, Edit  can be performed by  

right clicking the mouse button. 

 (Applies only to FSM,TTS) 

 



5.5  FOD, FSM(TTS), SDT Edit Window  
 
5.5.1 FOD Edit Window 

5.5.1.1  Full Screen 
 

 When a group node starting with g_ is double clicked  

 Window that can edit the FOD  

 

 

  

5.5.1.2  Details 
 

 



5.5.1.3  Button 
 

 Select 
 Used to select each node and transition 

 After clicking the selection button, click the node and transition in the edit 

window with the left mouse button  

 Drag & drop is available for multiple selections. 

 

 

 IO node 
 Used to edit input output nodes. 

 IO node can only be connected to one outgoing transition or incoming 

transition. 

 IO node can only be created in the top most FOD; once created in the top 

most FOD it is automatically created in the lower FOD. 

 When an IO node is deleted from a lower FOD, the transition from the top 

most FOD is deleted, but the IO node itself is not deleted. 

 

1. Click the IO node button and click the left mouse button on the editing 

window.   

2. When a dialog box for entering the node’s name is shown, enter a node name 

and click ok. 

3. As soon as the node’s name is entered the node is edited.  

 

 

 Group node 

 Used to edit group nodes starting with g_. 

 If the name does not begin with a g_, an error message is given and the name 

is re-entered. 

 

1. Click the group node button and click the left mouse button on the edit 

window.  

2. When a dialog box for entering the node’s name is shown, enter a node name 

and click ok. 

3. As soon as the node’s name is entered the node is edited.  

 

 

Function node 

 Used to edit function nodes starting with f_. 

 If the name does not begin with a f_, an error message is given and the name 

is re-entered. 

 



1. Click the function node button and click the left mouse button on the edit 

window.  

2. When a dialog box for entering the node’s name is shown, enter a node name 

and click ok. 

3. When a dialog box for entering the node’s name is shown, enter a node name 

and click ok. 

 

 

History node 

 Used to edit history nodes starting with h_. 

 If the name does not begin with a h_, an error message is given and the name 

is re-entered. 

 

1. Click the history node button and click the left mouse button on the edit 

window.  

2. When a dialog box for entering the node’s name is shown, enter a node name 

and click ok. 

3. When a dialog box for entering the node’s name is shown, enter a node name 

and click ok. 

 

 

Timed History node 

 Used to edit timed history nodes starting with th_. 

 If the name does not begin with a th_, an error message is given and the 

name is re-entered. 

 

 

1. Click the timed history node button and click the left mouse button on the edit 

window.  

2. When a dialog box for entering the node’s name is shown, enter a node name 

and click ok. 

3. When a dialog box for entering the node’s name is shown, enter a node name 

and click ok. 

 

 

 Transition 

 Used to edit transitions between nodes. 

 A Self-Transition in FOD is not allowed. 

 After clicking the Transition button once, multiple transitions can be drawn 

until another button is clicked. 

 As soon as a transition from an IO node is drawn, we decide whether it is an 

input or output node, and this information change automatically in the 

description window. 



1. Click the Transition button. 

2. Click and drag the Source node, and drop it at the Destination node. 

 When making a transition between group nodes, must input a transition 

name. 

 A transition name must be one of the output nodes’ names from the 

source group node. 

 When a group node  group node transition is drawn, a input node 

with the same name is automatically created in the target group node. 

 When a transition name is not one of the output node’s names in the 

source group node, then an output node with the corresponding name 

is automatically created. 

 

 

 
5.5.1.4  Rename Node 

 

1. Select the node, right click and select Rename. 

 

 
 

 



2. Change the name when the node name becomes a changeable state, 

then click the left mouse button and the renaming is done. 

 

 
 



 

5.5.2 SDT Edit Window 
5.5.2.1  Full Screen 

 
 When double clicked a node starting with f_  

 A table-like window that can edit SDT  

 

 

5.5.2.2  Details 

 

 



 

 

 

 

 

 Structured Decision Table 

 A table based on NuSCR semantics. 

 By clicking the right mouse button at each row/column, a row/column can be 

added, copied, pasted, deleted etc. 

 

 

5.5.3 FSM, TTS Edit Window 

5.5.3.1  FullScreen 
 

 When a node starting with h_, th_ is double clicked  

 A window that can edit FSM and TTS  

 



 
 

 
 

5.5.3.2  Details 
 

 
 
 
 
 
 
 



5.5.3.3  Button 
 

 Select 
 Used to select the State and transition. 

 After clicking the Selection button, click the left mouse button on the state 

and transition to be edited in the edit window. 

 Drag & drop is possible for Multiple Selection. 

 

 

 State 

 Used to draw States. 

 A State name must not include blank spaces or symbols. 

 

1. Click the State button and click the left mouse button on the edit window. 

2. When a dialog box for entering the State name pops up, enter the State name 

and click ok. 

 If the State name is entered wrong, an error message is given and the 

name is re-entered. 

3. As soon as the State name is inputted, the state is edited. 

 

 

 Transition 

 Used to edit transitions between States. 

 In FSM and TTS, at most one self-Transition can be drawn. 

 Once clicking the Transition button once, many transitions can be drawn 

until another button is pressed. 

 

1. Click the Transition button. 

2. Click the Source state and drag, drop at the Target state. 

 

 



5.5.3.4  Rename State 
 

1. Click the state, right click and select Rename. 

 

 
 

 

2. Change the name when the node name becomes a changeable state, 

then click the left mouse button and the renaming is done. 

 

 



5.5.3.5  Set Initial State 
 

1. Click the state, then right click and select set initial state. 

 

 
 

 

2. The selected state becomes an initial state, and the original initial state 

becomes a normal state. 

 

 
 



5.6  Type Window 
 

 A window that records all variables used in the diagram, and allows 

editing of the variable types  

 

 

5.6.1 Edit Type Window 
 

1. Click the variable and double click. 

 

 



 
 

2. In the variable type dialog box select the type and click ok.  

 

 
 

 

 

3. The variable’s type has been changed. 

 

 

 
 
 

5.6.2 Other supported item functions 
 

 Check to make sure that variable names are not repeated 



5.7  Quick Check before Model Checking 

5.7.1 Verification > Quick Check 

 

1. Select Verification > Quick Check.  

 

 

 

 

 

 

 

 

 

 

 

 

 

2. See the result on the right of the Type Window. 

 

 Quick Check checks diagram which is being edited and child nodes of 

the diagram. 

 To check entire model, execute Quick Check when you are editing root 

node. 



5.7.2     Errors checked by Quick Check 

 

① Undefined Variable in SDT’s Condition, Action 

② Syntax Error in SDT Condition, Action 

③ More than one Action allocated in SDT Condition 

④ Undefined Variable in FSM, TTS Transition 

⑤ Syntax Error in FSM, TTS Transition  

⑥ FOD, FSM, TTS Node which has no transition 

⑦ Nodes unreachable from initial state in FSM, TTS 

⑧ Output Variable and Connected node have different names 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 



5.8 Model Checking using SMV 
5.8.1 Verification > Model Checking 

 

1. Select Verification > Model Checking. 

 

 
 

 

2. A result window that converts the current window’s NuSCR contents 

into SMV input language is given. 

 

 
 

 



 

 

3. After entering the verifying properties, click the Apply button and it is 

applied to the SMV input (SMV input window is editable) 

 

 
 

 

 

4. Click the Execution button and the SMV tool is executed. 

 

 
 

 

 



5. Click Prop > Verify or Verify all from SMV. 

 

 
 

 

 

6. Check the verification results and analyze. 

 

 
 

 

 

 

 

 


