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1 NuSRS 2.0 소개 
 

 NuSCR로 기술된 요구사항의 명세 및 검증을 지원하는 자동화 도구 

 

 NuSRS 2.0의 대표적 개선점 
 사용자 편의성 최대화 

 Edit 메뉴 (Copy, Paste, Delete) 추가 

 View 메뉴 (Zoom In, Zoom Out, Zoom Selected, Fit to Window, Auto Align) 

추가 

 보다 많은 정보의 가시화 

 Description, Type Window, Console Window 추가 

 편집시 철저한 일관성 검사 

 사용자의 입력오류를 최대한 방지하기 위한 자동생성 기능 및 오류 메시지 기능 강

화 

 사용자에게 친숙한 인터페이스 구현 

 

2 개발 및 실행 환경 
 

 개발 언어  
 Java 

 

 개발 환경  
 eclipse 3.1 (JDK 1.5) 

 

 사용 환경 
 Windows OS(권장) 

 JDK 또는 JRE (ver. 1.5 이상)가 설치되어 있는 PC 

 

 

3 NuSRS 2.0 기능 구성 

 

 



4 화면 구성 

 

 
 
 

5 NuSRS 2.0 기능 상세 설명 

 
5.1  메뉴별 기능 

5.1.1   메뉴 > File 
 

 File 

 

 New –새로운 화일 생성 

 Open – 불러오기 

 Close File – 파일 닫기 

 Save – 저장하기 

 Save As – 다른 이름으로  

저장하기 

 Save Without Graphical Info  

– 그림 정보 없이 저장하기  

 Save as Image – 그림으로 저장하기  

 Print – 프린트하기  

 Exit – 프로그램 종료  

 
 

 



5.1.2   메뉴 > Edit 

 
 Edit 

 
 Cut – 선택된 영역을 잘라내기 

 Copy – 선택된 영역을 복사 

 Paste – 복사된 영역을 붙여넣기  

 Delete – 선택된 영역을 삭제  

 Select All – 현재 창에 있는 모든 객체를 선택  

 

 

 

 

 

 

 

5.1.3   메뉴 > View 

 
 View 

 
 FIND – 찾기  

 View IO Vars – I/O Variable을 보여줌 

 Zoom In – 확대 

 Zoom Out – 축소 

 Zoom Selected – 선택된  

영역을 확대 

 Fit to Window – 윈도우 사이즈에 맞게 

 확대 또는 축소 

 Auto Align – 자동 배치 

 

 

 

 

5.1.4   메뉴 > Window 
 Window 

 
 Close – 현재 편집중인 창을 닫아줌 

 Close All Windows – 현재 열려 있는 모든 
창을 닫아줌 

 

 

 

 

 

 

 



5.1.5       메뉴 > Help 
 

 Help 

 
 About – NuSRS 프로그램의 정보를 보여줌 

 
 
 
 
 
 
 

 
 
 
5.1.6   새화일 작성 

  
1. 메뉴에서 File > New 를 선택한다. 

 

 
 



2. Hierarchy 및 Description Window에 Root가 생성되고, Root 노드를 그릴 

수 있는 윈도우가 생성된다.  

 

 
 

 

 

5.1.7   불러오기 

 

1. 메뉴에서 File > Open을 선택한다  

 NuSRS에서 작성된 .xml 확장자 를 가진 파일 대상 

 

 

 



  

2. 대화상자가 열리면 불러오고 싶은 파일을 선택한다.  

 

 
 

 

 

3. 불러오기가 완료되었다. 

 

 



5.1.8   저장하기 
 

1. 메뉴에서 File > Save 를 선택한다. 현재 작업중인 파일이 저장된다. 

 

 
 

 
 

5.1.9   다른 이름으로 저장하기 
 

1. 메뉴에서 File > Save As를 선택한다. 

 

 



 

 

2. 대화상자가 열리면 저장하고 싶은 파일명을 입력한 뒤 저장을 클릭한다. 

현재 작업중 파일이 저장된다. 

 

 
 

5.1.10     그래픽 정보 없이 저장하기 
 

1. 메뉴에서 File > Save Without Graphical Info를 선택한다. 

 

 



2. 대화상자가 열리면 저장하고 싶은 파일명을 입력한 뒤 저장을 클릭한다. 

현재 작업 중 파일이 그래픽 정보를 제외하고 저장된다. 

 

 
 

 

5.1.11 이미지로 저장하기 
1. 메뉴에서 File > Save as Image 를 선택한다. 

 

 

 

 

 



2. 대화상자가 열리면 저장하고 싶은 파일명을 입력한 뒤 저장을 클릭한다. 

현재 작업 중 파일이 이미지로 저장된다. 

 

 
 

 

5.1.12 프린트하기 

 
1.  메뉴에서 File > Print를 선택한다. 

 
 



5.1.13 편집 > 잘라내기 
1. 마우스 왼쪽 클릭 또는 drag & drop으로 잘라내고자 하는 영역을 선택한

다. 

 
2. 메뉴에서 Edit > Cut 을 선택한다. 

또는 Ctrl + X 를 누른다. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



5.1.14 편집 > 복사 
 

1. 마우스 왼쪽 클릭 또는 drag & drop으로 복사하고자 하는 영역을 선택한

다. 

 

 

 

2. Edit > Copy 를 선택한다. 선택된 영역이 복사된다. 

Ctrl + C를 눌러서 동일한 효과를 낼 수 있다. 

 
 



5.1.15 편집 > 붙여넣기 
 

1. Edit > Paste 를 선택한다.  또는 Ctrl + V를 누른다. 

 

 
 

2. 복사된 영역이 있으면 붙여 넣어지며, 이름은 기존의 이름들과 다른 이름

으로 자동생성된다. 

 

 
 



3. 붙여넣기 한 노드를 선택하고 마우스 오른쪽을 클릭하여 Rename을 선택

한다. 

 

 
 

 

 

4. 붙여넣기 한 노드의 자동생성된 이름을 적절히 변경한다. 

 

 
 



 

 

5.1.16 편집 > 삭제 

 
1. 마우스 왼쪽 클릭 또는 drag & drop으로 삭제하고자 하는 영역을 선택한

다. 

 

 
 

2. Edit > Delete를 선택한다. 

Delete 키를 눌러도 된다. 

 



3. 선택된 영역이 삭제된다. 

 

 
 

5.1.17 편집 > 모두 선택 

 
1. Edit > Select All을 선택한다.(Ctrl + A 로도 가능) 

 

 
 



2. 모든 노드가 선택된다. 

 
 

5.1.18 보기 > 찾기 

 
1. View > Find를 선택한다. 

 

 
 

 



2. 나타난 Dialog에 찾고자 하는 노드의 이름을 입력한다. 

 
 

3. 찾아진 노드로 focus가 이동한다. 

 
 
 
 
 
 
 



5.1.19 보기 > I/O Variable 보기 

 
1. View > View IO Vars를 선택한다. 

 

 
 

 

2. I/O Variable의 리스트가 나타난다. 

 
 
 



5.1.20 보기 > 확대 

 
1. View > Zoom In을 선택한다. 

키 패드의 + 키로도 가능하다. 

 
 

 

 

2. 현재 활성화되어 있는 창의 그림이 확대된다. 

 

 



5.1.21 보기 > 축소 

 
1. View > Zoom Out을 선택한다. 

키패드의 – 키로도 가능하다. 

 
 

 

 

2. 현재 활성화되어 있는 창의 그림이 축소된다. 

 

 



5.1.22 보기 > 선택영역 확대 

 
1. 마우스 왼쪽 클릭 또는 drag & drop으로 삭제하고자 하는 영역을 선택한

다. 

 

 
 

 

 

2. View > Zoom Selected를 선택한다. 

 

 



3. 현재 선택되어 있는 영역이 창 전체에 차도록 창의 그림이 확대된다. 

 

 
 

 

 

5.1.23 보기 > 화면 크기에 맞춤 

 
1. View > Fit to Window를 선택한다. 

 

 
 



2. 현재 활성화되어 있는 창의 그림이 창의 크기에 맞게 조정된다. 

 

 
 

 

 

5.1.24 보기 > 자동 배치 
 

1. View > Auto Align을 선택한다. 

 

 



2. 현재 활성화되어 있는 창의 노드 및 전이들 위치가 자동 조정되어 배치된

다. 

 

 
 

 

5.1.25 창 닫기 
 

1. Window > Close 를 선택한다. 현재 활성화되어 있는 창이 닫힌다. 

 

 



5.1.26 모든 창 닫기 

 
1. Window > Close All 을 선택한다.  

 

 
 

 

 

2. 현재 열려져 있는 모든 창이 닫힌다. 

 

 



5.1.27 프로그램 정보 조회 

 
1. Help > About 을 선택한다. 

 

 
 

 

 

2. NuSRS 프로그램 정보가 표시된다. 

 

 



5.2  툴바 
 

 
 

5.3  Hierarchy Window 
 

 Hierarchy Window는 파일 내 FOD들간의  

계층 구조를 보여준다. 

 Root는 최상위 FOD를 가리킨다. 

 트리의 가지를 더블 클릭하면 해당 FOD가  

열리거나 열려있는 해당 FOD가 활성화된다. 

 Maximize 버튼 

 



5.4  Description Window 
 

 현재 활성화되어 있는 창에 대한 상세 정보를  

보여준다. 

 FOD 이름 

 Description 윈도우는 현재 활성화되어 있는 창의  

이름(노드 이름)을 root로 가진다. 

 Maximize 버튼 

 

 

 

 

 

 

 Description 

 현재 활성화된 다이어그램에 대한 설명을 기록한다. 

 종이 모양 아이콘에 대고 마우스 왼쪽 버튼을  

더블클릭하면 편집할 수 있다. 

 (FOD,SDT,FSM,TTS 모두 해당) 

 

 

 

 

 

 

 

 

 

 Template Number 

 FSM,TTS로 표현되는 논리는 일정한 형식의  

template을 가지고 있다. 해당 template number를  

입력해 준다. 

 종이 모양 아이콘에 대고 마우스 왼쪽 버튼을  

더블클릭하면 편집할 수 있다. 

 (FSM, TTS만 해당) 

 

 

 

 

 

 



 Input 

 현재 활성화된 창의 입력변수를 모두 보여준다.  

 Description 창에서 직접 수정은 불가능하다. 

 최상위 FOD에서 입력변수 이름이 변경된 경우,  

하위 노드에서의 해당 입력 변수이름도 자동으로  

변경된다. 

 (FOD,SDT,FSM,TTS 모두 해당)  

 

 

 

 

 

 

 Output 

 현재 활성화된 창의 출력변수를 보여준다.  

 Description 창에서 직접 수정은 불가능하다. 

 최상위 FOD에서 출력변수 이름이 변경된 경우,  

하위 노드에서의 해당 출력 변수이름도 자동으로  

변경된다. 

 f_, h_, th_ 노드들은 Output 변수가 하나이다. 

 (FOD,SDT,FSM,TTS 모두 해당)  

 

 

 

 

 

 

 Memorizable Variable of External input 

 입력변수의 이전 주기값을 가리키는 변수를 선언한다. 

 입력변수명 뒤에 _t0, _t1 과 같은 접미어를 붙여서  

몇 주기 전 값인지를 표현한다.  

 t0는 한 주기 전, t1은 두 주기 전 등 

 Memorizable variable of External input를 선택,  

마우스 오른쪽 클릭하면 변수를 Add, Delete, Edit  

할 수 있다. 

 (FSM,TTS만 해당) 

 

 

 

 

 

 



 Constant 

 해당 다이어그램에서 사용되는 상수값을 선언한다. 

 Constant를 선택, 마우스 오른쪽 클릭하면 상수를  

Add, Delete, Edit 할 수 있다. 

 (FOD,SDT,FSM,TTS 모두 해당) 

 

 

 

 

 

 

 

 

 Local Clock Variable 

 Transition label에 시간에 관한 조건을 사용하는  

TTS의 경우, Clock Variable을 선언해 주어야 한다. 

 Local Clock Variable을 선택, 마우스 오른쪽  

클릭하면 변수를 Add, Delete, Edit 할 수 있다. 

 (TTS만 해당) 

 

 

 

 

 

 

 

 

 Previous State Variable 

 출력변수의 이전 주기값을 가리키는 변수를 선언한다. 

 출력변수명 뒤에 _t0, _t1 과 같은 접미어를 붙여서  

몇 주기 전 값인지를 표현한다.  

 t0는 한 주기 전, t1은 두 주기 전 등 

 Previous State Variable을 선택, 마우스 오른쪽  

클릭하면 변수를 Add, Delete, Edit 할 수 있다. 

 (FSM,TTS만 해당) 

 



5.5  FOD, FSM(TTS), SDT 편집창  

 
5.5.1 FOD 편집창 

5.5.1.1  전체 화면 

 

 g_로 시작되는 그룹 노드를 더블 클릭했을 경우 

 FOD를 도식할 수 있는 창 

 

 

 

5.5.1.2  세부 항목 
 

 



5.5.1.3  버튼 

 

 Select 
 각 노드 및 transition을 선택할 때 사용한다. 

 Selection 버튼을 누른 후, 편집창에서 선택하고자 하는 노드 및 transition 위

치에서 마우스 왼쪽버튼을 클릭한다. 

 Multiple Selection을 위한 마우스 drag&drop이 가능하다. 

 

 

 IO node 
 입출력 노드를 도식할 때 사용한다. 

 IO node는 나가는 transition이나 들어오는 transition 중 하나에만 연결될 수 

있다.  

 IO node는 최상위 FOD에서만 생성될 수 있으며, 최상위 FOD에서 생성되었을 

때 하위 FOD들에는 일관성 있게 자동으로 생성된다. 

 IO node를 하위 FOD에서 지우면, 상위 FOD에서는 해당 transition이 삭제되고, 

IO node자체는 삭제되지 않는다. 

 

1. IO node 버튼을 클릭하고 편집창에서 마우스 왼쪽버튼을 클릭한다.  

2. 노드 이름을 입력하는 대화창이 나오면, 노드 이름을 입력하고 확인을 클릭한다. 

3. 노드의 이름이 입력됨과 동시에 노드가 도식된다. 

 

 

 Group node 

 g_로 시작되는 그룹 노드를 도식할 때 사용한다. 

 이름이 g_로 시작하지 않는 경우에는 에러 메시지가 출력되고 이름을 다시 입력 

받는다. 

 

1. Group node 버튼을 클릭하고 편집창에서 마우스 왼쪽버튼을 클릭한다.  

2. 노드 이름을 입력하는 대화창이 나오면, 노드 이름을 입력하고 확인을 클릭한다. 

3. 노드의 이름이 입력됨과 동시에 노드가 도식된다. 

 

 

 Function node 

 f_로 시작되는 function 노드를 도식할 때 사용한다. 

 이름이 f_로 시작하지 않는 경우에는 에러 메시지가 출력되고 이름을 다시 입력 

받는다. 

 

1. Function node 버튼을 클릭하고 편집창에서 마우스 왼쪽버튼을 클릭한다.  

2. 노드 이름을 입력하는 대화창이 나오면, 노드 이름을 입력하고 확인을 클릭한다. 

3. 노드의 이름이 입력됨과 동시에 노드가 도식된다. 

 



 History node 

 History node를 도식할 때 사용한다. 

 이름이 h_로 시작하지 않는 경우에는 에러 메시지가 출력되고 이름을 다시 입력 

받는다. 

 

1. History node 버튼을 클릭하고 편집창에서 마우스 왼쪽버튼을 클릭한다.  

2. 노드 이름을 입력하는 대화창이 나오면, 노드 이름을 입력하고 확인을 클릭한다. 

3. 노드의 이름이 입력됨과 동시에 노드가 도식된다. 

 

 

 Timed History node 

 Timed History node를 도식할 때 사용 

 이름이 th_로시작하지 않는 경우에는 에러 메시지가 출력되고 이름을 다시 입력 

받는다. 

 

1. Timed History node 버튼을 클릭하고 편집창에서 마우스 왼쪽버튼을 클릭한다.  

2. 노드 이름을 입력하는 대화창이 나오면, 노드 이름을 입력하고 확인을 클릭한다. 

3. 노드의 이름이 입력됨과 동시에 노드가 도식된다. 

 

 

 Transition 

 노드간 transition을 도식할 때 사용한다. 

 FOD에서 Self-Transition은 허용되지 않는다. 

 Transition 버튼을 한 번 클릭한 후 다른 버튼을 누르기 전까지, 여러 개의 

Transition을 그릴 수 있다. 

 IO node는 그와 연결된 transition이 그려지는 순간 input node인지 output node

인지 결정이 되며, 이 정보는 Description창의 Input/Output 부분에 바로 반영된

다. 

 

1. Transition 버튼을 클릭한다. 

2. Source 노드를 클릭하고 drag해서, Destination 노드에서 drop한다. 

 Group node에서 Group node로의 transition을 그릴 때는 transition이름을 

입력해야 한다. 

 transition 이름은 source group node의 output node 이름 중 하나여야 

한다. 

 group 노드  group 노드 transition이 그려지면, 입력한 transition과 

같은 이름의 입력 노드가 target group node에 자동으로 생성된다. 

 transition 이름이 source group node의 output node 이름 중 하나가 

아닌 경우는 source group node에 transition과 같은 이름의 output 

node가 자동으로 생성된다. 

 

 

 



5.5.1.4  노드 이름 변경 
 

1. 노드를 선택, 오른쪽 클릭하고 Rename을 선택한다. 

 

 
 

 

2. 노드 이름이 편집할 수 있는 상태로 바뀌면 노드 이름을 변경하고, 마우스 

왼쪽을 클릭해 주면 노드 이름 변경이 완료된다. 

 

 



5.5.2 SDT 편집창 

5.5.2.1  전체 화면 

 
 f_로 시작되는 노드를 더블 클릭했을 경우 

 SDT를 도식할 수 있는 테이블 형태의 창 

 

 
 

 

 

5.5.2.2  세부 사항 

 

 



 

 

 

 Structured Decision Table 

 NuSCR의 semantics에 의거하여 구성된 table 

 각 행과 열에서 오른쪽 마우스를 클릭하면 행, 열의 추가와 삭제, 복사, 붙여넣기, 

지우기 등이 가능하다. 

 

 

5.5.3 FSM, TTS 편집창 

5.5.3.1  전체 화면 
 

 h_, th_로 시작되는 노드를 더블 클릭했을 경우 

 FSM및 TTS를 도식할 수 있는 창 

 

 



5.5.3.2  세부 항목 

 

 
 
 
 
 

5.5.3.3  버튼 
 

 Select 
 State 및 transition을 선택할 때 사용한다. 

 Selection 버튼을 누른 후, 편집창에서 선택하고자 하는 State 및 transition 위

치에서 마우스 왼쪽버튼을 클릭한다. 

 Multiple Selection을 위한 마우스 drag&drop이 가능하다. 

 

 

 State 

 State를 그릴 때 사용한다. 

 State 이름에는 공백이나 특수문자가 포함되어서는 안 된다. 

 

1. State 버튼을 클릭하고 편집창에서 마우스 왼쪽버튼을 클릭한다. 

2. State 이름을 입력하는 대화창이 나오면, State 이름을 입력하고 확인을 클릭한

다. 

 State 이름을 잘못 입력한 경우에는 에러 메시지가 출력되고 이름을 다시 입

력 받는다. 

3. State의 이름이 입력됨과 동시에 state가 도식된다. 

 

 

 Transition 



 State간 transition을 도식할 때 사용한다. 

 FSM 및 TTS에서는 최대 한 개까지만 Self-Transition을 그릴 수 있다. 

 Transition 버튼을 한 번 클릭한 후 다른 버튼을 누르기 전까지, 여러 개의 

Transition을 그릴 수 있다. 

 

1. Transition 버튼을 클릭한다. 

2. Source state를 클릭하고 drag해서, Target state에서 drop한다. 

 

 

 

 

5.5.3.4  상태 이름 변경 
 

1. 상태를 선택, 오른쪽 클릭하고 Rename을 선택한다. 

 

 
 

 

 

 

 

 

 

 

 

 

 



2. 상태 이름이 편집할 수 있는 상태로 바뀌면 상태 이름을 변경하고, 마우스 

왼쪽을 클릭해 주면 노드 이름 변경이 완료된다. 

 

 
 

 

5.5.3.5  초기 상태 변경 
 

1. 상태를 선택, 오른쪽 클릭하고 Set Initial State를 선택한다. 

 

 



2. 선택한 상태가 초기 상태로 바뀌고, 기존의 초기 상태는 보통 상태로 돌아

간다.  

 

 
 

5.6  Type Window 
 

 활성화된 다이어그램에 사용된 모든 변수들을 기록하고, 각 변수의 타입

을 편집할 수 있는 창 

 

 



5.6.1 Type Window 편집 
 

1. 변수를 선택, 더블클릭한다. 

 

 

 
2. 변수 타입 입력창에서 변수의 타입을 선택 및 입력하고 OK를 누른다.  

 

 
 

 

 

 

 

 

 



3. 변수의 타입이 변경되었다. 

 

 

 
 
 

5.6.2 그 외 명세 지원 기능 

 
 변수 이름이 중복되지 않도록 체크 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



5.7 Quick Check before Model Checking 

5.7.1 검증 > Quick Check 

 

1. Verification > Quick Check을 선택한다.  

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Type Window 우측의 결과를 확인한다. 

 

 Quick Check는 현재 편집중인 FOD, SDT 혹은 FSM/TTS와 그 하위 요소

까지 모두 체크한다. 

 Root 노드의 편집 중에 Quick Check를 실행하면 전체 모델에 대해 

Check를 수행한다.   



5.7.2     Quick Check 항목 

 

① SDT Condition, Action의 Undefined Variable 

② SDT Condition, Action에서 연산자 사용 잘못  

③ SDT에서 한 개의 Condition에 둘 이상의 Action 할당  

④ FSM, TTS Transition의 Undefined Variable 

⑤ FSM, TTS Transition의 연산자 사용 잘못  

⑥ FOD, FSM, TTS에서 Transition이 없는 노드  

⑦ FSM, TTS에서 Initial State로부터 Unrechable 노드  

⑧ FOD에서 Output 변수와 연결된 노드 동일 명칭 체크  

 

 

 

 

 



5.8  Model Checking using SMV 

5.8.1 검증 > 모델체킹 

 

1. Verification > Model Checking을 선택한다. 

 

 
 

 

 

2. 현재 활성화된 창의 NuSCR 명세를 SMV입력언어로 변환한 결과 창이 뜬

다. 

 

 
 



3. 검증속성을 입력 후, Apply 버튼을 누르면 SMV 입력에 반영된다. (SMV 

입력창 편집 가능) 

 

 
 

 

 

4. Execution버튼을 누르면 SMV 도구가 실행된다. 

 

 
 

 

 



5. SMV에서 Prop > Verify 또는 Verify all을 선택한다. 

 

 

 
 

 

 

6. 검증결과를 확인하고 분석한다. 

 

 
 

 

 

 

 

 


