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Junit AF-& 9

e Java —Exl‘srcanntfest.iiva - Eclipse SDK _- - -

Edit Source Refactor Navigate Search Project Run Window Help

New Alt+Shift+N ¥ |2} Java Project
Open File... I Project..
Close ctri+w | # Package
Close Al Ctrl+shiftsw | @ Class o
@ Interface
Save Ctrl+S @ Enum y
Bl Save As... ) @ Annotation t:
Save All Ctrl+Shift+S &% Source Folder
Revert ¥ Java Working Set b
Move... % Folder
¢ File 0 T i e) E
Rename... F2 |Y E | 01 v__.\] U O A
#) Refresh 5 | B Untitled Text File s C Ipse A T n It =2 7 T
e H t
Convert Line Delimiters To  ([Ed)UnitTest Case i O }\
Print Ctrl+p 9 Other... Ctrl+N - _—i A
Switch Workspace 4 }
Restart S @Test
i Import public veoi
ed Export... 3 fait(®
Properties Alt+Enter

1 ArrayList.java [Ex1/src]
2 Printjava [Ex1/src]

3 PrintTestjava [Ex1/src]
4 Ex1testjava [Ex1/src]

Exit




Test building

e New JUnit Test Case

= =] % |

JUnit Test Case

!5 The use of the default package is discouraged.

() New JUnit 2 test @ New JUnit 4 test

Source folder:  Calcuator/src

Package:
Name: CalcuatorTest
Superclass: java.lang.Object

Which method stubs would you like to create?
setUpBeforeClass() [¥| tearDownAfterClass()
setUp() tearDown()

constructor

"] Generate comments

Class under test: Calcuator

et

Do you want to add comments? (Configure templates and default value here

El

Browse...

Browse...

———
 ——
{————

Browse...

@ < Back Next = ] [ Finish

] { Cancel

JUnit 342X &
Source code 74 =

Test Fixture




Main class

public class Calcuator {

public double
add(double n1, double n2)
{ mmm T3] QAR
return nl + n2; /I Integer Return Method
}

}




testl

import junit.framework.TestCase; assertEquals=-©] &3t | =8
A =5 MO E FA
public class TestCalcuator
extends TestCase {
public void testAdd(){

Calcuator calcuator=new
Calcuator();

double
resu Itzcalcuator.add(l,Z); . Htl TestCalcuator2 [Runner: JUnit 4] (0.0C

assertEquals(3,result,0);
117] t %k (expected) 2}H2) Al gk (actual) ©] 24| 1] al

}

gt JUnit &2 = a8

BE u§| QD EH e v
Finished after 0.023 seconds

Runs: 1/1 BErrors: 0 8 Failures: 0




test2

: . < E)
import junit.framework.TestCase; assertEquals = B~
A A w7k 0 7
. = ﬂ_ - .‘_‘
public class TestCalcuator2 WERH AL FUnitE A
extends TestCase {
public void testAdd(){ v JUnit 52 = &
Calcuator calcuator=new Lo g mE~
Ca]cua’[or()' Finished after 0.044 seconds
double Runs: 1/1 ®Errors: 0 B Failures: 1
result=calcuator.add(1,2); ]
asserteEquals(5,result,0); 4 fiil TestCalcuator2 [Runner: JUnit 4] (0.0¢
Il 71 0] %k (expected) 2 #l| gk (actual) o] 722 1] 1L & testAdd (0.000 s)

}
}




All test

import junit.framework.TestSuite;
import junit.framework.Test;
import junit.textui.TestRunner;
public class TestAll extends TestSuite
{

public static Test suite() {

TestSuite suite = new

TestSuite(" TestSuite Test");

addTestSuitetl| 2 E F | =
F7HE 2" class ) o 271 <]
TestE 255 ol 2T wf 2220

suite.addTestSuite(TestCalcuator.class);

suite.addTestSuite(TestCalcuator2.class);
return suite;

}

public static void main(String

args|[]N
TestRunner.run(suite());

1




H2~E 28 4
«  (@Before Test method7} A &% 7] Ao A& %= method
e (@Before Class
o - TestE Al&sl7]dol ghHvr Aagsh
« (@After Test method’} A& ¥ W+ 3
« (@After Class

1=
o A3J% = method

o - TestE vzl sk vk Ao

*  (@Test

e - Test® A3 method kel &<

. - expected

BT Aow qEE A9E AF. dert AVA o A,
* - timeout

«  HZEEVE Eus ARbE oS5 ARG AA v A,

e (@Ignore

- H2AEE 4] %S method &oll &9
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Eclipse )| 3™

i =10l x|
File Edit MNawigate Search Ero]ect Bun  Window Help
| -EE8.&||% || ¢||% -2 -
2 T Mavigator - X x l
B | = & Eclipse Platform
This page will help familiarize you with the Eclipse Workbench, =
To get started, read the sections below and click on the related links,
@ Installed Features
Ta find aut mare about the features installed in yvour warkbench, choose Help = Welcome.,
and select the feature you are interested in,
@ Perspectives. views and editors . . . . .
& window contains one ar more perspectives, A perspective consists of wiews (e.g. Navigatar)
and editors for working with wour resources,
The shortcut bar at the far left of the window allows you to open new perspectives and move b
between perspectives that are already open. The perspective you are currently warking with
is shown in the title of the window and in the shorcut bar as a pushed-in icon,
@ Configuring your perspectives
= - You can maove views and editors around the workbench by dragging their titebars, ¥ou can
= Outline b4 also add mare views to yaur current Ferspectwe by using Window > Show View,
" GG [ mik EvEEsE To reset the perspective to its original state, choose Window > Reset Perspective,
Once you have arranged your perspective, you can save it using Window > Save Perspective As....
You can customize the views, perspectives and MNew menu operations that show up for
your persPectwe. To do this choose Window > Custornize Perspective,,. . & view can -
At 1 b st e . TaTH b | H H 3 o b ot T +
¢ Tasks (0 iterns) B = v x
[ «| ' | Description | Aesource [ In Folder | Location |
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Come i Crsninrs S O |
lose tl+Shift+ L
File hse Platform
s o = Oth [ ill help familiari ith
Other,,, nis page will help familiarize you wi
W Save 45, get started, read the sections below
& Save Al Ctrl+Shift+5
Installed Features
fievert @ To find out more about the features
M and select the feature you are inter
ove,,,
flename. . = Perspectives, views and edito
& window containg one of more pe
fefresh and aeditors for working with your re
& Erint,,. il +F The shartcut bar at the far left of the
between perspectives that are alrez
ig shown in the title of the window :
g2y Impart...
e Export... i% Configuring your perspectives
You can move views and editors ar
Properties Slt+Enter ® also add rnore views fo wour currer
- To reset the perspective to its origir
Extt Once vou have arranged your pers|
¥ou can customize the views, pers
yaur persPectwe. To do this choos
Aditime =l kb oo d ot E.
v Tasks (0 itemns)
| v [ 1| Description
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Java - Eclipse Platform

File Edit Source Refactor Mavigate Search Project Hun  Window Help
5 - |5 -% %-[[oado-||e 7]
g v x
By | S
@ | d = Froject,..
Go Into
Open in Mew Window . F‘ackge

Open Type Hierarchy

i lass

o Cuit

2 Copy
I Paste
# Delete

sSource

WQEEHF Refactar

@ Interface
@ Source Folder
ii™ Scrapbook Page
= Folder

File

»
» =\ Other,

= o b
2= Outline g3 Import...

An oufling s 1 223 Export,.,

ir Pefrash
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£ Java - HelloWarld,java - Eclipse Platfarm

Eile

Edit Source Refactor MNavigate

Search  Project Bun  Window Help

| -EHE S| 3 &%

IEIL‘FIﬂ

Run As

f2 Package Explarer

s

F Run...

B E. HelloJava
EI E} softwareExample
i @4 HelloWorld, java
- Wi, JRE Systemn Library [j2se]

G
* Eiz i NEYE .-‘-'-.pplet

I® 7% c-s -

Ju 3 JUnit Test 3.

& 4 Run-time Workbench

ate for thi

Package Explnrer] Hierarchy

8= Outline 3 13ae o x

~-H}  softwareExample
=@ HellaWorld

o 5 hello @ Sting
- @ 9 main{String[])

®f

’il**

w

#

{

# Windowegt:Preferencessght; Javas

packayge softuwareExawple:

* @Gaunthor Administrator

% To change the template for thi
* Windowggt:Preferencessgt: Jawvad

public class HelloWorld

private static btring hello =

public static wvoid main| 3tri
{

System.out.println{ hellc
i
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& X| & Hstepl:
Help -> Install New Software
44

Window |Help |

@ Welcome

(@ Help Contents
2 Search

Dynamic Help

Key Assist... Ctrl+Shift+L
Tips and Tricks...
Cheat Sheets...

Check for Updates
Install Mew Software...

About Eclipse SDK

.'rﬂ'.

What's New

. - ) ]
W/ Find out what is new
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& x| 2 EHstep? :
Add 2¢} Location :
http://andrei.gmxhome.de/eclipse/

Available Software _
- |
Select a site or enter the location of a site. L)
Work with: type or select a site - Add...

Find more software by working with the "Available Software Sites" preferences.

type filter text , & Add Repository &J

Name

@ There is nq | Name: | Local...
Location: http:// Archive...

Select All E . E—
L @ OK Cancel

Details
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& X| & Hstep3:
name= 2| ecilpse 3.6-4.3 plugins
=3 ‘Next HESZZ.

Work with: jdepend - http://andrei.gmxhome.de/eclipse - Add...

Find more software by working with the "Available Software Sites" preferences.

type filter text

Name Version
[ Eclipse 3.5 - 3.8 plugins
i Eclipse 3.5 - 4.3 plugins

m

i Eclipse 3.5 plugins
' |00 Eclipse 3.6 - 4.3 plugins

Select All ‘ | Deselect All 2 items selected
Details
Show only the latest versions of available software v| Hide items that are already installed
¥| Group items by category What is already installed?

Show only software applicable to target environment

| Contact all update sites during install to find required software

I
=
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= X 2 & step4:
OlH A "next” ” finish” HE= =2 OfcH
2tH0| L= L L.

? & Installing Software l | =l Hh‘

Installing Software

[ ]iAlways run in background:

Run in Eackgmund| | Cancel | | Details == |
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2 ot= I XU CIt Run Jdepend analysis

Calcuator

= src

4| ft (default package &=
- [B Calcuator.java [E
- [ TestAlljava | ¥
- [1] TestCalcuator
- [1] TestCalcuator

=i JRE System Library

= JUnit 4

 ——
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It backaae) - Calcuator

Show In

Copy

Copy Qualified Name
Paste

Delete

Build Path

Source

Refactor

Import...

Export...

References
Declarations

Find Bugs

Refresh

Assign Working Sets...

Compare With

Restore from Local History...

Debug As

Run As

Run JDepend analysis
Team

Properties

Alt+Shift+WwW »
Ctrl+C

Ctrl+Vv
Delete

>
Alt+Shift+S »
Alt+Shift+T»

F5

Alt+Enter

i3

uk

—_.

E




H4 Packages 2 p@|EE ~=0 %4 Dependencies 2

4 t default Selected object(s)
© Calcuatorjava Package CC{co.. AC(ab... Ca(aff) Ce(eff) A Cycle!
© TestAlljava
® TestCalcuatorjava .
© TestCalcuator2.java Packages with cycle
Pac kag eS Package CC(co.. AC(ab.. Ca(aff) Ce(eff) A Cycle!
Depends upon - efferent dependencies
Package CC{co... AC(ab.. Ca(aff) Cefeff) A Cycle!
H Metrics = 8
Instability ->
: Used by - afferent dependencies
: Package CC(co... AC(ab.. Ca(aff) Ce(eff) A Cycle!

Metrics Dependencies
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Packages

P71 A o= AR
T+ A=
4 Packages i G @|EE V=0
4 fff default
© Calcuator.java
© TestAlljava

© TestCalcuator.java
© TestCalcuator2.java
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Package

f#tjunit.framework
ff junit.textui

Dependencies View

K 5)7] 4 o] o
FA ARE 5A 5
sto] 19
CC(concr.cl) AC(abstrcl) Ca(aff) Cefeff) A I
0 0 1 0 0.00 0.0
0 0 1 0 0.00 0.0

)

1.00
1.00

Cycle!
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Dependencies View
2ol o g 74 9

CC : Interface, Abstract ClassE Al 2/ 8t Concrete class2| 2=
AC =42l AL Interface? i, S & HO T,
Ca: &M WIIXC ZHAU &0t U= WIIK S = MU HEIt &,
Ce:&H WIIXC ZHA=0| 2 =0ot) Y= WIKIL = =
NS AT E LIEFUD, 0~1 AHOIS] gH2 JIHE. 02 &N
FMAOITIIIXE LIEFHCE
S0 CHet ot 8 A= LHEHLHDG, O~1 AtOI2] &8t= JIHE. 02 218 B3l &
NELl= WIIX0IH, 02 H=2H30HE 2 =2 = e WIIKE LIEHHCTE
D: Main SequenceZ2FH 2| H2lE UEtULHEH, 02 Main Sequence®t Jt&2 1, 12 H
/\I-EH
Cycle JlHDlIlC AS ZOH SlEH= N US [

O| S| CD*EI

2l A
s ESR T DN R=:

J>

I—l

2t Of

-




Metrics View
Dependencies ©l| 4]
T2 stE ARE 1

PIE BolE

B Metrics 2

Instability ->

M

Abstractness




o] A} QlPackage = 73} 7| 2

Very High o] F-o] A 2l o Qb4 A<l
Stability Package & <] W] &ttt
Interface | stapility —

Packages ity

,Z\bstractness N

Abstractness




¥4 Packages 2 ¢ @|[EE Y=o %3 Dep

- 8 default IShowJDepend output !
DependenC|eS Oﬂ }\ll %4 Dependencies B Console &2
{_":j‘l ﬂ_% ch) E.% JDepend
Consoled A] Bl A E T s

o 7bs e

Mame, Class Count, Abstract Class Count, Ca, Ce, A, I, D, V:

Default,4,0,0,2,0,1,0,1
junit.framework,®,9,1,0,0,0,1,1
junit.textuvi,®,e,1,0,0,0,1,1
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Clover

Clover®@ 8 3}+= o]
H| ~Eof o5 = o] ofu A A ek=A] &<l
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Clover A ] Ui stepl

Eclipsel 4 help->Install new software’ &}

T

http://update.atlassian.com/eclipse/clover

Work with: clover - http://atlassian.com/software/clover - | Add... |

Find more software by working with the "Available Software Sites”

Ereferen::es. i

i & Add Repository ﬁ
Name: clover | Local... | [
Location: http://atlassian.com/software/clover | Archive... |

[ () OK || Cancel |




Clover A %] "} step2
next...

Name Version
4+ Clover 3 (for Eclipse 3.6 - 4.3 and RAD 8.0 - 8.5)  3.2.2.wv20140207000000
4t Clover 3 Ant Support (for Eclipse 3.6 - 4.3 and RA 3.2.2.v20140207000000

< n »

Size: Unknown
Details

* This release is a bug fix release. * A

@ Py e | T T




Clover A %] "I step3
finish Click

(") 1do not accept the terms of the |

:I Next > Einish ‘ | Cancel ‘




Eclipse menuol A/ Window->Show View->Other

% Show View

==n X

type filter text

: (= General
» = Ant
: = APl Tools
4 = Clover
I 8 Clover Dashboard
 Coverage Explorer
8 Test Contributions
@ Test Run Explorer
= CVS
: = Debug

: = FindBugs
. = Haln

1

20 reorm=rn

oK

Cancel

) Clover Dashbo.. & 8 Coverage Expl.. @ Test Contribut.. @ Test Run Expl..




Coverage explorer

UnitTestE A 2t gk}, 15l ofgff of 2ho]
H2~E FZ=7F dulyCoverdl =4
Percentage = U E}F AT}

@

Show: [AII classes "]
Elem Cov% Av Me Cpx Cpx
_ 35.3% __

4 B (default package) T 25.3%

v I Calcuator.java T 100.0% 1.0 1.0
» [ TestAlljava I 0.0% 1.0 2.0
p TestCalcuator.java D 0.0% 1.0 1.0
v 4 TestCalcuator2.java 1 100.0% 1.0 1.0
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Coverage Dashboard

Coverage
Test Coverage 2] H]-&ol tj 3k

Coverage 1 d L2/ 2 el ts
XC:I)E‘ g classes, 2/ 2 elemen

=
Test Results roese

HAE Ao tigh A H
Most Complex Packages Test Results 1/ 1 tests 0.05 secs
100%

7HE 534S 71X PackageE

HojFEoh

Most Complex Classes

714 534 & 71 Class&

==

TEO% ;L—E]— . Most Complex Classes
op Project Risks 1. 100%: [ Calcuator (1)

7V J3bekal A2 Test

Coverages 7}%l Class&

H o] F=T)

Least Tested Methods

7} w2 Test Coverage 2|

Methods< K. of =t}

Most Complex Packages
1. 100% [N d=fault-pkg (1)

Top 0 Project Risks

Least Tested Methods




Java Editor

PULLLL Lld>> dliudLunr g

public double add(double nl, double n2) {
return nl + n2;
TestE &4 3HAH Main }
Method* 9 2] 5- TestE sl = ¥
2}l N

public static Test suite() {
TestSuite suite = new TestSuite("TestSuite T

21 7)) 3} Test Coverage
ElJH 9 suite.addTestSuite(TestCalcuator.class);

Bl 7} Al N 3
=1 L‘ suite.addTestSuite(TestCalcuator2.class);
Coverage”} 1+ Code return suite;
§j XH
AH
Aeld = \

import junit.framework.TestSuite; []
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Coverage Treemap Report

‘PackageE2 & &2
ol =C}.

AP E O
AJ|l=complexity&2
BHS

2 AC label =

E0otXl F=C.
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Coverage Treemap Report

& =744 7 Coverage® Project 5=+ PackageE 47 23t}
& Package(labeled) = Y31 22k class(unlabeled)® X o] =T},
®Package B-+=Class®] 7]+ 584 & YeERAT

& 272 = codecoveraged] 4 =& LEFATE
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Thank you!

The end




